EU Server Maintenance - critical security updates
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jan 19, 2018 - 03:11 UTC
Monitoring
EU servers are undergoing scheduled maintenance at 02:00 GMT to apply critical security updates. Access to dashboard (reporting, etc) affected.
Posted Jan 18, 2018 - 22:04 UTC