Data center issue
Incident Report for SMTP2GO
Resolved
Faulty hardware has been replaced. Service restored.
Posted Oct 27, 2016 - 05:03 UTC
Investigating
We are investigating an issue at one of the data centers that is affecting some members. Any email is being queued - expect slightly delayed delivery. Member dashboard can be accessed directly: https://app.smtp2go.com/login/
Posted Oct 27, 2016 - 02:32 UTC