SMTP2GO website undergoing maintenance
Incident Report for SMTP2GO
Resolved
SMTP2GO website is online.
Posted Oct 18, 2016 - 08:27 UTC
Identified
SMTP2GO website is currently undergoing maintenance. This does NOT affect email sending.
Posted Oct 18, 2016 - 08:06 UTC