Emails delayed
Incident Report for SMTP2GO
Resolved
Our main upstream provider (one of the largest in the US) had routing issues for a few minutes which has since been resolved.
Posted Aug 25, 2016 - 03:09 UTC
Identified
We have been alerted to an issue which is delaying emails from being delivered. This is currently being investigated.
Posted Aug 25, 2016 - 02:46 UTC