Website and some mail issues being investigated
Incident Report for SMTP2GO
Resolved
An upstream internet provider router fault caused a minor outage. This is now corrected but we are continuing to monitor this to ensure no repeat.
Posted Nov 30, 2016 - 22:08 UTC
Investigating
An upstream provider has gone offline which is affecting some customers. We are working to restore connections.
Posted Nov 30, 2016 - 21:23 UTC