User Dashboard: Unscheduled Downtime
Incident Report for SMTP2GO
Resolved
This incident has been resolved. Please contact support at [email protected] if you're still unable to access the dashboard.
Posted Aug 03, 2021 - 17:05 UTC
Investigating
Our development team is currently investigating a problem with the user dashboard. Users may be unable to sign into the dashboard or reset their passwords for the time being.
Posted Aug 03, 2021 - 16:09 UTC
This incident affected: Member Dashboard.