Potential Sending Delays: Inbound Server
Incident Report for SMTP2GO
Resolved
This incident has been resolved. If you have any remaining emails held as "Processed" or would like further clarification, please contact [email protected].
Posted Jun 01, 2021 - 20:40 UTC
Investigating
We are currently investigating this issue.
Posted Jun 01, 2021 - 15:32 UTC
This incident affected: Email sending (SMTP service).