Potential Downtime: Inbound Server
Incident Report for SMTP2GO
Resolved
The issue with one of our inbound servers has been identified and a fix has been deployed. If you're still experiencing delivery delays, please contact support at [email protected]. Thank you all for your patience and understanding.
Posted 21 days ago. Aug 28, 2019 - 19:13 UTC
Investigating
We are currently investigating a possible outage regarding one of our inbound servers that may be causing connection issues and delays. Thank you for your patience!
Posted 21 days ago. Aug 28, 2019 - 15:42 UTC
This incident affected: Email sending (SMTP service).