User Dashboard: Unscheduled Downtime
Incident Report for SMTP2GO
Resolved
This incident has been resolved. If you're still unable to log in or reset your password, please contact support at [email protected].
Posted Jun 13, 2022 - 15:39 UTC
Investigating
We are currently investigating this issue.
Posted Jun 13, 2022 - 14:32 UTC
This incident affected: Member Dashboard.