Outage of one outbound
Incident Report for SMTP2GO
Resolved
This incident has been resolved and backlogged email are being sent.
Posted Jan 03, 2022 - 21:11 UTC
Investigating
We have identified an outage that is affecting one of our outbound servers, which is currently impacting a portion of our customers. This is being worked on by our developers for a fix asap.
Posted Jan 03, 2022 - 15:49 UTC
This incident affected: Email sending (SMTP service).