"Processed" Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved. Users still experiencing delivery delays or connectivity issues are advised to contact support via [email protected] for further assistance.
Posted Oct 13, 2022 - 19:29 UTC
Investigating
We are currently investigating a connectivity issue.
Posted Oct 13, 2022 - 15:57 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 13, 2022 - 15:17 UTC
Investigating
We are currently investigating an issue with emails stuck in "processed" status. Users may experience delivery delays during this time.
Posted Oct 13, 2022 - 13:42 UTC
This incident affected: Email sending (SMTP service).