"Processed" Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved. If you're still experiencing delays, please contact support via [email protected].
Posted Apr 12, 2022 - 19:48 UTC
Investigating
We are currently investigating an issue with "processed" emails. Users may experience delivery delays.
Posted Apr 12, 2022 - 19:07 UTC
This incident affected: Email sending (SMTP service).