User Dashboard: Unscheduled Downtime
Incident Report for SMTP2GO
Resolved
User dashboard access has been restored. If you're still unable to sign in or make changes to your account, please contact support at [email protected].
Posted Aug 05, 2021 - 20:35 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 05, 2021 - 20:10 UTC
Investigating
We are currently investigating this issue.
Posted Aug 05, 2021 - 16:01 UTC
This incident affected: Member Dashboard.