Processed Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Sep 23, 2021 - 11:45 UTC
Update
We are continuing to investigate this issue.
Posted Sep 23, 2021 - 09:27 UTC
Investigating
Unexpected high loading has caused a slow down in deliveries for some users.
Posted Sep 23, 2021 - 09:26 UTC
This incident affected: Email sending (SMTP service).