DOS attack
Incident Report for SMTP2GO
Resolved
Some mail delivery times affected, service restored.
Posted Oct 21, 2016 - 04:25 UTC
Monitoring
We are currently seeing a DOS attack on our service, and are working to block it.
Posted Oct 21, 2016 - 03:15 UTC