Processed Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Nov 25, 2021 - 14:08 UTC
Update
We are continuing to investigate this issue.
Posted Nov 25, 2021 - 14:08 UTC
Investigating
Some users may experience some delays in delivery.

We are currently investigating and working on a fix.
Posted Nov 25, 2021 - 13:12 UTC
This incident affected: Email sending (SMTP service).