Unscheduled Downtime
Incident Report for SMTP2GO
Resolved
This incident has been resolved. Please reach out to support ([email protected]) if you're still unable to send email.
Posted Oct 18, 2021 - 20:53 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 18, 2021 - 20:32 UTC
Investigating
Users may be unable to send email due to authentication errors (pop up messages asking to confirm the SMTP username and password). Our development team is currently investigating the issue.
Posted Oct 18, 2021 - 20:14 UTC
This incident affected: Email sending (SMTP service).