Possible outage for European customers

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jul 17, 2019 - 12:48 UTC

Investigating

We are currently investigating the issue and will update once resolved.
Posted Jul 17, 2019 - 12:06 UTC