Processed Emails
Incident Report for SMTP2GO
Resolved
This incident has been resolved. Any remaining processed emails will be sent shortly.
Posted Sep 20, 2022 - 11:31 UTC
Investigating
You may see "Processed" emails under the activity feed and delays in delivery.
Posted Sep 20, 2022 - 10:22 UTC
This incident affected: Email sending (SMTP service).