EU Routing Issue

Incident Report for SMTP2GO

Resolved

The rollback has been successful and email is flowing normally again.
Posted May 06, 2025 - 06:10 UTC

Identified

An upstream provider has caused the routing issue and is currently rolling back the changes made.
Posted May 06, 2025 - 06:08 UTC

Investigating

We are currently investigating routing issues in the EU. This may mean delayed delivery.
Posted May 06, 2025 - 04:18 UTC
This incident affected: Email sending (SMTP service) and API Servers.