Possible outage for European customers
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 17, 2019 - 13:57 UTC
Investigating
As previously stated, this issue is still at large and has not been resolved. It is being investigated as a matter of urgency.
Posted Jul 17, 2019 - 13:08 UTC