East Coast Internet Outage
Incident Report for SMTP2GO
Resolved
DOS attack at core data center.
Posted Jul 10, 2018 - 04:00 UTC
Monitoring
Some email delayed due to internet outage on the East Coast of the USA.
Posted Jul 10, 2018 - 01:14 UTC
This incident affected: Email sending (SMTP service).