Possible outage for European customers
Incident Report for SMTP2GO
Resolved
Thank you for your patience! An EU-based server temporarily stopped responding, but the problem is now resolved. Please contact us at [email protected] should any issues return or persist.
Posted 15 days ago. Aug 02, 2019 - 19:00 UTC
Investigating
We are currently investigating the issue and will update once resolved.
Posted 15 days ago. Aug 02, 2019 - 14:16 UTC
This incident affected: Email sending (SMTP service).