Invoice display issue
Incident Report for SMTP2GO
Resolved
This incident has been resolved by our payment processor. Please contact support at [email protected] if you're still unable to access your invoices.
Posted Feb 10, 2022 - 18:54 UTC
Monitoring
Some customers may find their invoices are not displaying in their dashboard. We are working with our payments team to resolve this issue.
Posted Feb 10, 2022 - 09:33 UTC