Server outage
Incident Report for SMTP2GO
Resolved
Services are being restored. Email has been queued during this outage and is now being delivered.
Posted Jul 06, 2018 - 14:30 UTC
Identified
Issue ongoing. Engineers on site working to resolve as soon as possible.
Posted Jul 06, 2018 - 13:27 UTC
Investigating
We are currently investigating an issue that is affecting a small number of customers. More information to follow.
Posted Jul 06, 2018 - 12:07 UTC
This incident affected: Email sending (SMTP service).