Potential Downtime: Inbound Server
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted May 30, 2020 - 22:05 UTC
Update
SSL Certificate Issue. If you are unable to connect to our servers, please try turning TLS/SSL off. Our developers are still working to resolve the certificate issue. If you continue to have problems connecting, please contact us at [email protected].
Posted May 30, 2020 - 14:29 UTC
Investigating
Our development team is currently investigating this issue.
Posted May 30, 2020 - 13:34 UTC