Server load
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 08, 2019 - 02:41 UTC
Monitoring
We have identified some server loading issues which have resulted in slower than expected delivery times. We are reallocating resources to alleviate this burden. All sent mail is still being queued for delivery and will be sent shortly. This affects a small number of users.
Posted 3 months ago. Mar 07, 2019 - 22:30 UTC
This incident affected: Email sending (SMTP service).