Potential Downtime: Inbound Server
Incident Report for SMTP2GO
Resolved
The problem with our offline inbound server has been identified, and a fix has been deployed. If you're still experiencing delivery delays, please contact support at tick[email protected]. Thank you!
Posted Aug 27, 2019 - 20:21 UTC
Investigating
We're currently investigating a possible outage regarding one of our inbound servers. Thank you for your patience!
Posted Aug 27, 2019 - 15:06 UTC
This incident affected: Email sending (SMTP service).