Database Servers Down
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jul 12, 2018 - 15:43 UTC
Investigating
Investigating Degraded Performance, Please See ServInt's Status Page for More Information: https://servint.statuspage.io
Posted Jul 12, 2018 - 14:54 UTC
This incident affected: Email sending (SMTP service), SMTP2GO Website, and API Servers.