User Dashboard: Inaccurate Activity Data
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Mar 09, 2021 - 22:25 UTC
Identified
The problem has been identified, and our development team is actively working on a solution.
Posted Mar 09, 2021 - 19:09 UTC
Investigating
We are investigating an issue regarding inaccurate delivery status reports for the user dashboard. Delivered emails are being reported as "Processed".
Posted Mar 09, 2021 - 17:31 UTC
This incident affected: Member Dashboard.