Phishing/Scam
Incident Report for SMTP2GO
Resolved
We're marking this as resolved, but some emails will still be arriving in inboxes. Please follow the security advisory as described in previous incident updates.
Posted 16 days ago. Aug 01, 2019 - 00:45 UTC
Update
Note:
Always check for "https:" at the start of any link that appears to be sent by us. Always feel welcome to question any email, we're happy to check - just contact our support team.
Posted 17 days ago. Jul 31, 2019 - 21:48 UTC
Identified
We've discovered a phishing website that is cloning the login page for SMTP2GO customers. Please do not click on any links from emails with the subject line: "Update your payment information now".

We're doing our best to have the site taken down. If you need further support, please contact us: [email protected]
Posted 17 days ago. Jul 31, 2019 - 21:29 UTC