Critical security updates
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Jan 17, 2018 - 16:31 UTC
Update
Monitoring - As part of our ongoing commitment to keeping customer data secure, our servers are being updated with critical security updates. This means that servers will be offline for short periods of time over the next few days. Your email should still be queued and delivered later. Please contact support if you have any queries.
Posted Jan 17, 2018 - 13:45 UTC
Monitoring
As part of our ongoing commitment to keeping customer data secure, our servers are being updated with critical security updates. This means that servers will be offline for short periods of time over the next few days. Your email should still be queued and delivered later. Please contact support if you have any queries.
Posted Jan 17, 2018 - 10:26 UTC