"Processed" Emails
Incident Report for SMTP2GO
Resolved
Unexpected high loading caused a slow down in deliveries. This has been resolved and emails have been delivered.
Posted Aug 25, 2021 - 23:55 UTC
Investigating
We are currently investigating an issue with emails stuck in "processed" status. Please standby for updates.
Posted Aug 25, 2021 - 19:46 UTC
This incident affected: Email sending (SMTP service).