Delivery delays to Microsoft-hosted recipients

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted May 22, 2025 - 09:44 UTC

Identified

Some customers sending to Microsoft-hosted recipients may see delays with email delivery due to an ongoing issue from their side, which they are currently working to resolve. Affected emails will have the event status of "Processed" and "421 4.3.2 The maximum number of concurrent connections per resource forest has exceeded a limit, closing transmission channel" events when viewing the email's Timeline, instead of normal delivery events. We continue to attempt delivery of these emails. For more details, 365 Admin users can go here: https://admin.cloud.microsoft/?#/servicehealth/:/alerts/EX1079935
Posted May 22, 2025 - 06:41 UTC
This incident affected: Email sending (SMTP service).