Email Delays (US)
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Feb 08, 2023 - 12:05 UTC
Monitoring
We have implemented a workaround whilst our provider continues to monitor the issue from their side.
Posted Feb 08, 2023 - 09:13 UTC
Identified
We regret that one of our major hosting providers is currently suffering an issue with their network, which is causing massive bandwidth reductions. We are waiting for updates from them and will advise as soon as the situation is fully resolved.

These delays should only affect some users in the US.
Posted Feb 08, 2023 - 06:41 UTC
This incident affected: Email sending (SMTP service).