Connectivity Issues and Delivery Delays
Incident Report for SMTP2GO
Resolved
This incident has been solved.
Posted Jun 06, 2024 - 21:17 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2024 - 21:08 UTC
Identified
Our team has identified that there is an issue and they are currently issuing a fix.
Posted Jun 06, 2024 - 20:52 UTC
Investigating
We are currently experiencing an issue with some of our servers, our team is investigating and will update this page as information becomes available.
Posted Jun 06, 2024 - 20:43 UTC
This incident affected: Email sending (SMTP service).