Delivery Delays

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Jan 24, 2026 - 00:26 UTC

Identified

Our team has identified a global service outage affecting Microsoft.

As a result, outbound emails to Microsoft-hosted domains may be delayed. We are securely holding affected messages and will continue to automatically re-attempt delivery until Microsoft resolves the issue.
Posted Jan 22, 2026 - 20:02 UTC

Investigating

We are currently investigating an issue affecting the mail servers. During this time, users may experience delays in email delivery.
Posted Jan 22, 2026 - 19:44 UTC
This incident affected: Email sending (SMTP service).