"Activity" Reporting Delay: EU Customers

Incident Report for SMTP2GO

Resolved

This incident has been resolved. If you still have emails showing as "Processed" only, please reach out to our support team who can assist further.
Posted Aug 19, 2026 - 06:01 UTC

Investigating

European users may experience a delay in delivery statuses being updated in the dashboard. Our developers are currently working on a fix. Please rest assured that the emails have been delivered successfully despite the delayed status updates.
Posted Aug 18, 2026 - 16:47 UTC
This incident affected: Member Dashboard.