Connectivity issues for "mail-au.smtp2go.com"

Incident Report for SMTP2GO

Resolved

This issue has now been resolved, and services are operating normally. We apologise for any inconvenience this may have caused. If you continue to experience any connection failures when connecting to "mail-au.smtp2go.com", please reach out to our support team for assistance.
Posted Feb 09, 2026 - 02:51 UTC

Identified

Some customers may experience intermittent connection failures when connecting to "mail-au.smtp2go.com". Our development team has identified the issue and is taking corrective action to restore full stability as quickly as possible.
Recommended Action: While we resolve this, you can maintain a stable connection by switching your SMTP server address to "mail.smtp2go.com".
Posted Feb 08, 2026 - 23:57 UTC
This incident affected: Email sending (SMTP service).