Delivery delays
Incident Report for SMTP2GO
Resolved
The delays were due to a minor resource allocation issue resulting in emails being queued - this temporarily affected delivery for a small number of AU-based customers. Please contact support if you encounter any further delivery issues.
Posted Nov 29, 2023 - 05:38 UTC
Monitoring
The issue was identified and a resolution has been implemented. Email queues are now clearing and we are continuing to monitor.
Posted Nov 29, 2023 - 03:30 UTC
Investigating
We are currently investigating reports of delays.
Posted Nov 29, 2023 - 03:07 UTC
This incident affected: Email sending (SMTP service).