Emails queued as "Pending"
Incident Report for SMTP2GO
Resolved
An unexpected hardware failure is the root cause of today's issue. We have replaced the affected server.
Posted Feb 10, 2020 - 00:02 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 09, 2020 - 22:51 UTC
Monitoring
Queued email is now sending and the backlog is being cleared.
Posted Feb 09, 2020 - 22:05 UTC
Identified
Our engineering team is working to resolve this issue. It is affecting a small number of customers where emails are accepted for delivery but not yet completely sent. Email is queuing and will be sent as soon as a hot fix is deployed.
Posted Feb 09, 2020 - 20:46 UTC
This incident affected: Email sending (SMTP service).