Subaccounts: Verified Senders Issue

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 23:28 UTC

Monitoring

A fix has been implemented, and we're continuing to monitor. If you encounter any further issues granting subaccounts access to verified sender domains, please reach out to our support team.
Posted Nov 13, 2025 - 21:48 UTC

Investigating

Some users may be experiencing issues with subaccount management. Our team is currently investigating an error affecting the ability to share verified senders between master accounts and their associated subaccounts.
Posted Nov 13, 2025 - 15:40 UTC
This incident affected: Member Dashboard.