A resolution has been implemented and we're continuing to monitor. While the backlog of "Processed" emails is clearing, clients may notice a temporary delay in event updates (such as the "Delivered" status) appearing in the Activity page reporting. These records are being processed and will be fully updated shortly.
Posted Apr 01, 2026 - 05:28 UTC
Update
A preliminary fix is being implemented and the backlog of processed email is being worked through.
Posted Apr 01, 2026 - 02:09 UTC
Identified
The issue has been identified, and a fix is being implemented.
Posted Mar 31, 2026 - 23:58 UTC
Investigating
We are investigating an issue causing delays in email delivery in the AU region. These emails will appear as "Processed" on the "Reports > Activity" page. Our engineering team is currently working to identify the root cause and restore normal processing speeds as quickly as possible.
Posted Mar 31, 2026 - 23:08 UTC
This incident affects: Email sending (SMTP service).