Issues with email delays affecting some accounts
Incident Report for SMTP2GO
Resolved
This incident has now been resolved. Note: almost all emails have now been delivered, and any remaining emails are expected to be delivered shortly.
Posted Aug 16, 2024 - 11:59 UTC
Identified
The issue has been identified and a fix is being implemented. We will update with more information as soon as we have it.
Posted Aug 16, 2024 - 09:31 UTC
Investigating
We have received reports that some accounts are experiencing delays in email delivery. We are currently investigating the issue with urgency.
Posted Aug 16, 2024 - 08:16 UTC
This incident affected: Email sending (SMTP service).