Issue with Microsoft MX
Incident Report for SMTP2GO
Resolved
This incident has been resolved.
Posted Oct 11, 2023 - 22:48 UTC
Update
For those who cannot view Microsoft's status page on this incident, this is from their latest update from a few minutes ago:

Current status: We’re progressing with the testing and development stage of our fix, to ensure its efficacy prior to deployment. We expect to be able to provide an estimate time of completion by the time of the next scheduled update.
Next update by: Wednesday, October 11, 2023, at 4:30 PM UTC
Posted Oct 11, 2023 - 14:42 UTC
Monitoring
Some clients are experiencing issues with delays when emailing Microsoft email addresses. We were made aware of the issue this morning, and have contacted Microsoft several times. They have just acknowledged that there is indeed a problem on their end which they are investigating.

Our servers will continue attempting to deliver your emails and we hope that Microsoft will resolve the issue soon. If you are a Microsoft Customer, we'd also recommend that you get in touch with them as well for further assistance. You can also view Microsoft's status page which mentions the incident, by logging into Microsoft's admin center (if you are a customer), and going to 'Microsoft Admin Center - Health - Service health - scroll down - Service Status'.
Posted Oct 11, 2023 - 10:36 UTC