Delivery issue to some Microsoft MX
Incident Report for SMTP2GO
Resolved
We are aware that some clients may be experiencing issues when sending to Microsoft recipients. After further investigation, our developers have determined that the problem originates on Microsoft's side.

Although we will continue to reach out to Microsoft to investigate the issue further, if you are a Microsoft Customer, we'd also recommend that you get in touch with them as well for further assistance.

UPDATE: Microsoft has acknowledged that there is an issue on their side and they are investigating.
Posted Oct 11, 2023 - 06:28 UTC
Investigating
We are currently investigating this issue.
Posted Oct 11, 2023 - 03:51 UTC
This incident affected: Email sending (SMTP service).