Delivery Delays (emails held as "Processed") - AU region

Incident Report for SMTP2GO

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 08:59 UTC

Update

With further improvements now in place, we are continuing to monitor the system to ensure delivery times return to normal.
Posted Oct 01, 2025 - 03:53 UTC

Monitoring

The email backlogs are clearing, and we are continuing to monitor.
Posted Oct 01, 2025 - 02:19 UTC

Identified

We've identified the cause of recent email delivery delays in the AU region. Our team is currently implementing a fix, and the backlog of emails should begin clearing shortly. We apologize for any inconvenience this may have caused.
Posted Oct 01, 2025 - 01:45 UTC
This incident affected: Email sending (SMTP service).