User Dashboard: Unscheduled Downtime
Incident Report for SMTP2GO
Resolved
The issue with the user dashboard has been resolved. If you're still unable to sign in or reset your password, please contact support at [email protected].
Posted Oct 01, 2021 - 20:15 UTC
Investigating
We are currently investigating this issue.
Posted Oct 01, 2021 - 19:18 UTC
This incident affected: Member Dashboard.