Service has returned to normal, and we are continuing to monitor closely. Our upstream provider, Linode (Akamai), experienced unforeseen issues, which you can read more about on their status page: https://status.linode.com/incidents/6yw88b0ft94g
We apologize for any inconvenience this caused our customers. If you have further questions or experience issues with sending, account access, or App slowness, please don't hesitate to reach out to our support team for assistance.
Posted Jul 28, 2025 - 04:26 UTC
Monitoring
The remaining mail queues are now clearing with service returning to normal. We are continuing to monitor. If you encounter any further issues, please let our support team know. Thank you for your continued patience.
Posted Jul 28, 2025 - 00:32 UTC
Update
Our US provider is continuing to investigate and is making progress towards a resolution at the affected location. Emails for some customers will be delayed and we are actively working to re-route emails to mitigate this as much as possible. The status page for the US provider will provide more immediate updates as they come to hand: https://status.linode.com/incidents/6yw88b0ft94g We are aware of the significant impact this is causing to some customers.
Posted Jul 27, 2025 - 22:00 UTC
Update
Our US provider is continuing to investigate the issue. At present, some services are still affected. If you have any issues connecting to mail.smtp2go.com, you may be trying to connect to an IP located at the affected data centre. If so, please try 43.228.184.6 instead of mail.smtp2go.com to ensure connection to a different data centre. If that works, then use that until our Status Page has been updated, then you can revert back to mail.smtp2go.com. Otherwise, contact support at [email protected]
Posted Jul 27, 2025 - 18:39 UTC
Identified
We have received an update from our provider who have informed us that the problem was related to heating/cooling complications in one location due to a power outage. The power outage has been fixed, and they are working quickly to bring the services back online. We have seen improvements to Login access and app/dashboard speed, but will continue to monitor.
Posted Jul 27, 2025 - 14:18 UTC
Investigating
We have been notified of an issue at one of our US providers' locations. This may cause login issues and some app slowness. The provider is currently investigating the issue. In the meantime, please try logging in at https://app-eu.smtp2go.com where possible.