Delivery Delays

Incident Report for SMTP2GO

Resolved

This incident is now resolved. Please reach out to our support team if you notice any further delays.

We are sorry for the inconvenience caused.
Posted Sep 01, 2025 - 10:37 UTC

Investigating

We are aware of some delivery delays affecting a small number of customers and are working to resolve this as quickly as possible.
Posted Sep 01, 2025 - 02:07 UTC
This incident affected: Email sending (SMTP service).